码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1142 A Walk Through the Forest (Dijkstra + 记忆化搜索)

时间:2015-01-21 13:33:59      阅读:178      评论:0      收藏:0      [点我收藏+]

标签:

A Walk Through the Forest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5984    Accepted Submission(s): 2211


Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable. 
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take. 
 

Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections. 
 

Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647
 

Sample Input
5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0
 

Sample Output
2 4
 

Source



题意:一片森林里有一个人,从家去工作要穿越整个森林,他现在想从工作的地方回家。森林里有n个地点,m条路,工作地点编号为1,家编号为2.他想经过这样的地点k:从地点k到家的距离比任意从工作地点到家的距离都短,问这样的地点有多少个?


解析:先用Dijkstra处理反向一下,记录从他家到各个地点的最短路径,然后再用记忆化搜索,计算家到工作地点的路径总条数。



AC代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
#define INF 1e7 + 2
const int maxn = 1000 + 5;

int n, m;
int w[maxn][maxn], d[maxn], v[maxn];
int ans[maxn];               //answer

void dijkstra(int s){
    memset(v, 0, sizeof(v));
    for(int i=1; i<=n; i++) d[i] = i==s ? 0 : INF;
    for(int i=1; i<=n; i++){
        int x, m = INF;
        for(int y=1; y<=n; y++)
            if(!v[y] && d[y] <= m) m = d[x = y];
        v[x] = 1;
        for(int y=1; y<=n; y++) d[y] = min(d[y], d[x] + w[x][y]);
    }
}

int dfs(int k, int n){
    if(ans[k]) return ans[k];                //记忆化,否则超时!!!
    if(k == 2) return 1;
    for(int i=1; i<=n; i++){
        if(w[k][i] < INF && d[k] > d[i])     //满足条件
            ans[k] += dfs(i, n);
    }
    return ans[k];
}

int main(){
    #ifdef sxk
        freopen("in.txt", "r", stdin);
    #endif //sxk

    int x, y, z;
    while(scanf("%d%d", &n, &m)!=EOF && n){
        memset(ans, 0, sizeof(ans));
        for(int i=1; i<=n; i++)
            for(int j=1; j<=i; j++)
                w[i][j] = w[j][i] = i==j ? 0 : INF;
        for(int i=0; i<m; i++){
            scanf("%d%d%d", &x, &y, &z);
            w[x][y] = w[y][x] = min(w[x][y], z);
        }
        dijkstra(2);                      //家作为源点
        printf("%d\n", dfs(1, n));
    }
    return 0;
}





hdu 1142 A Walk Through the Forest (Dijkstra + 记忆化搜索)

标签:

原文地址:http://blog.csdn.net/u013446688/article/details/42966087

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!