码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1217 Arbitrage (Floyd + 最大路径)

时间:2015-01-21 18:16:14      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:

Arbitrage

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4899    Accepted Submission(s): 2241


Problem Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
 

Input
The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n. 
 

Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No". 
 

Sample Input
3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0
 

Sample Output
Case 1: Yes Case 2: No
 

Source



题意:已知n种货币,m对互相兑换的汇率,问是否能够通过货币之间的流转盈利。


解析:Floyd算法,不过是求最大路径,而且汇率之间是乘法的关系。最后只需判断是否存在大于1的环即可。




AC代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <map>
#include <string>
using namespace std;
#define INF 123456
#define MAX_V 35
#define MAX_E 1005

double d[MAX_V][MAX_V];
int n, m;

void Floyd(){
    for(int k=1; k<=n; k++)
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                d[i][j] = max(d[i][j], d[i][k] * d[k][j]);        //乘法,最大值max
}

int main(){
    #ifdef sxk
        freopen("in.txt", "r", stdin);
    #endif //sxk

    int t = 0;
    string s, e;
    double rate;
    map<string, int> a;
    while(scanf("%d", &n)!=EOF && n){
        for(int i=1; i<=n; i++){                  
            cin>>s;
            a[s] = i;                         //用map将字符串映射为数字
        }
        for(int i=1; i<=n; i++)
        for(int j=1; j<=n; j++) d[i][j] = (i==j) ? 1 : 0;      //注意初始化
        scanf("%d", &m);
        for(int i=1; i<=m; i++){
            cin>>s>>rate>>e;
            d[ a[s] ][ a[e] ] = max(d[ a[s] ][ a[e] ], rate);   //更新d值
        }
        Floyd();
        printf("Case %d: %s\n", ++t, d[1][1] > 1 ? "Yes" : "No");
        a.clear();
    }
    return 0;
}





hdu 1217 Arbitrage (Floyd + 最大路径)

标签:

原文地址:http://blog.csdn.net/u013446688/article/details/42970055

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!