标签:c++ cpp 编程 计算机 指针
Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to
move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
Output
Print the total time on a single line for each test case.
Sample Input
Sample Output
代码
#include<iostream>
using namespace std;
int main()
{
int N,*a,min;
while(cin>>N)
{
if(N==0)
return 0;
a=new int[N];
min=0;
for(int i=0; i<N; i++)
{
cin>>a[i];
}
for(int i=0; i<N; i++)
{
if(i==0)
min=6*a[i]+5;
else if(a[i]>a[i-1])
min=min+(a[i]-a[i-1])*6+5;
else
min=min+(a[i-1]-a[i])*4+5;
}
delete []a;
a=NULL;
cout<<min<<endl;
}
return 0;
}
一些项目——elevator problem
标签:c++ cpp 编程 计算机 指针
原文地址:http://blog.csdn.net/blue_skyrim/article/details/42970325