码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1058 Humble Numbers

时间:2015-01-22 00:01:40      阅读:165      评论:0      收藏:0      [点我收藏+]

标签:

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18406    Accepted Submission(s): 8010


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
 

 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

 

Sample Input
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

 

Sample Output
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
 
刚开始做这题时一看就是简单的模拟,但一看2000000000肯定超时,后来看了一下别人做的才知道的。
#include <iostream>
using namespace std;

int min(int a,int b,int c,int d)
{
    int t=a;
    if (b<a)
    a=b;
    if(c<a)
    a=c;
    if (d<a)
    a=d;
    return a;
}
int main()
{
    int s2,m,s3,s5,s7,n,a[6000];
    a[1]=1;
          s2=s3=s5=s7=1;
          m=1;
          while (a[m]<=2000000000)
          {
                m++;
                a[m]=min(2*a[s2],3*a[s3],5*a[s5],7*a[s7]);
                if (a[m]==2*a[s2])s2++;
                if (a[m]==5*a[s5])s5++;
                if (a[m]==3*a[s3])s3++;
                if (a[m]==7*a[s7])s7++;
          }
    while (cin>>n)
    {
          if (n==0)
          break;
          cout <<"The "<<n;
          int t=n%10;
          int tt=n%100;
          if (t==1&&tt!=11)
          cout <<"st ";
          else if (t==2&&tt!=12)
          cout <<"nd ";
          else if (t==3&&tt!=13)
          cout <<"rd ";
          else 
          cout <<"th ";
          cout <<"humble number is "<<a[n]<<"."<<endl;
    }
    return 0;
}

 

hdu 1058 Humble Numbers

标签:

原文地址:http://www.cnblogs.com/arno-my-boke/p/4240247.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!