码迷,mamicode.com
首页 > 其他好文 > 详细

poj1850--Code(组合篇2)

时间:2015-01-22 13:23:17      阅读:160      评论:0      收藏:0      [点我收藏+]

标签:

Code
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 8414   Accepted: 3983

Description

Transmitting and memorizing information is a task that requires different coding systems for the best use of the available space. A well known system is that one where a number is associated to a character sequence. It is considered that the words are made only of small characters of the English alphabet a,b,c, ..., z (26 characters). From all these words we consider only those whose letters are in lexigraphical order (each character is smaller than the next character).

The coding system works like this:
? The words are arranged in the increasing order of their length.
? The words with the same length are arranged in lexicographical order (the order from the dictionary).
? We codify these words by their numbering, starting with a, as follows:
a - 1
b - 2
...
z - 26
ab - 27
...
az - 51
bc - 52
...
vwxyz - 83681
...

Specify for a given word if it can be codified according to this coding system. For the affirmative case specify its code.

Input

The only line contains a word. There are some constraints:
? The word is maximum 10 letters length
? The English alphabet has 26 characters.

Output

The output will contain the code of the given word, or 0 if the word can not be codified.

Sample Input

bf

Sample Output

55

Source

 

给出一个字符串的字典中的编号,编号是升序的,否则输出0

dp[i][j] i记录这是字符串中的第i位字符,j代表以a到z开头 时的总数

num[i] 代表在第i位之前出现的个数。

按字符串从高位开始向后累加,注意最后加上字符串自身。

 

 

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;
#define LL __int64
LL dp[30][30] , num[30] ;
char str[30] ;
void init()
{
    int i , j , k ;
    memset(dp,0,sizeof(dp)) ;
    memset(num,0,sizeof(num)) ;
    for(j = 0 ; j < 26 ; j++)
        dp[1][j] = 1 ;
    for(i = 2 ; i <= 26 ; i++)
    {
        for(j = 0 ; j < 26 ; j++)
        {
            for(k = j+1 ; k < 26 ; k++)
                dp[i][j] += dp[i-1][k] ;
        }
        num[i] = num[i-1] ;
        for(j = 0 ; j < 26 ; j++)
            num[i] += dp[i-1][j] ;
    }
    return ;
}
int main()
{
    int i , j , l , k , last ;
    LL ans = 0 ;
    init() ;
    while( scanf("%s", str) != EOF )
    {
        l = strlen(str) ;
        for(i = 1 ; i < l ; i++)
            if( str[i-1] >= str[i] )
                break ;
        if( i < l )
        {
            printf("0\n") ;
            continue ;
        }
        ans = num[l] ; last = -1 ;
        for(i = l ; i >= 1 ; i--)
        {
            k = str[l-i] - 'a' ;
            for(j = last+1 ; j < k ; j++)
                ans += dp[i][j] ;
            last = k ;
        }
        ans++ ;
        printf("%I64d\n", ans) ;
    }
    return 0;
}


 

 

 

poj1850--Code(组合篇2)

标签:

原文地址:http://blog.csdn.net/winddreams/article/details/43017047

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!