码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3253 Fence Repair (贪心 + Huffman树)

时间:2015-01-22 15:34:54      阅读:208      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 28155   Accepted: 9146

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn‘t own a saw with which to cut the wood, so he mosies over to Farmer Don‘s Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn‘t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

Source




题意:有一块很长的木板,要切割成n小块,已知每块的长度。已知分割长为L的木板需要的费用是L,问完成所有切割最少需要多少费用。


解析:Huffman树的思想。我们可以倒过来看,我们不从最大开始分割,而是将分割好的小块一块一块拼回去,结果是一样的。这样的话,无疑就是最优二叉树——Huffman树,所有只要按照Huffman的思想写就行了。



AC代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;

int a[20002];

int main(){
    #ifdef sxk
        freopen("in.txt", "r", stdin);
    #endif //sxk
    int n, foo;
    while(scanf("%d", &n)!=EOF){
        priority_queue<int, vector<int>, greater<int> > a;
        for(int i=0; i<n; i++){
            scanf("%d", &foo);
            a.push(foo);
        }
        long long ans = 0;                  //int会WA
        for(int i=0; i<n-1; i++){           //每次取两个最小的
            int x = a.top(); a.pop();
            int y = a.top(); a.pop();
            ans += x + y;                   //记录拼接费用
            a.push(x + y);                  //拼接之后,再放回优先级队列中去
        }
        printf("%lld\n", ans);
    }
    return 0;
}




小编福利:Huffman树的思想还是很巧妙地,很多地方都能用到,没想到A题也能用到,还以为只有数据结构课上学的呢~~~




POJ 3253 Fence Repair (贪心 + Huffman树)

标签:

原文地址:http://blog.csdn.net/u013446688/article/details/43018607

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!