码迷,mamicode.com
首页 > 其他好文 > 详细

CDZSC_2015寒假新人(1)——基础 B

时间:2015-01-23 12:49:27      阅读:212      评论:0      收藏:0      [点我收藏+]

标签:

Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.       
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.       
              

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.       
              

Output

Print the total time on a single line for each test case.        
              

Sample Input

1 2
3 2 3 1
0
              

Sample Output

17
41 
 
技术分享
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
struct dangchi
{
    char str[20];
    int sum;
};
int main()
{
#ifdef CDZSC_OFFLINE
    freopen("in.txt","r",stdin);
#endif
    int n,a,b,sum;
    while(scanf("%d",&n)&&n!=0)
    {
        b=0,sum=0;
        while(n--)
        {
            scanf("%d",&a);
            if(a>b)
            {
                sum+=(a-b)*6+5;
                b=a;
            }
            else if(a<b)
            {
                sum+=(b-a)*4+5;
                b=a;
            }
            else
            {
                sum+=5;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}
View Code

 

      

CDZSC_2015寒假新人(1)——基础 B

标签:

原文地址:http://www.cnblogs.com/Wing0624/p/4243800.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!