码迷,mamicode.com
首页 > 其他好文 > 详细

CDZSC_2015寒假新人(1)——基础 C

时间:2015-01-23 13:04:48      阅读:148      评论:0      收藏:0      [点我收藏+]

标签:

Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.        The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.       
              

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1‘s. All integers are not greater than 1000.       
              

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.       
              

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
              

Sample Output

13.333
31.500
 
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
struct laoshu
{
    int j;
    int f;
    double s;
};
bool cmp(laoshu stud1,laoshu stud2)
{
    return stud1.s>stud2.s;
}
int main()
{
#ifdef CDZSC_OFFLINE
    freopen("in.txt","r",stdin);
#endif
    int i,m,n;
    double sum;
    laoshu stud[1010];
    while(scanf("%d%d",&m,&n)&&m!=-1&&n!=-1)
    {
        sum=0;
        for(i=0; i<n; i++)
        {
            scanf("%d%d",&stud[i].j,&stud[i].f);
            stud[i].s=1.0*stud[i].j/stud[i].f;
        }
        sort(stud,stud+n,cmp);
        for(i=0; i<n; i++)
        {
            if(m>=stud[i].f)
            {
                sum+=stud[i].j;
                m-=stud[i].f;
            }
            else
            {
                sum+=stud[i].s*m;
                break;
            }
        }
        printf("%.3lf\n",sum);
    }
    return 0;
}

 

CDZSC_2015寒假新人(1)——基础 C

标签:

原文地址:http://www.cnblogs.com/Wing0624/p/4243805.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!