码迷,mamicode.com
首页 > 其他好文 > 详细

CDZSC_2015寒假新人(1)——基础 G

时间:2015-01-23 13:10:17      阅读:115      评论:0      收藏:0      [点我收藏+]

标签:

Description

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.       
              

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.        Each test case contains a single line with several words. There will be at most 1000 characters in a line.       
              

Output

For each test case, you should output the text which is processed.       
              

Sample Input

3 olleh !dlrow
m‘I morf .udh
I ekil .mca
              

Sample Output

hello world!
I‘m from hdu.
I like acm.

Hint

Remember to use getchar() to read ‘\n‘ after the interger T, then you may use gets() to read a line and process it.

 

技术分享
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int main()
{
#ifdef CDZSC_OFFLINE
    freopen("in.txt","r",stdin);
#endif
    char str[1024],s[1024];
    int len,i,j,t,p,flag;
    scanf("%d",&t);
    getchar();
    while(t--)
    {
        cin.getline(str,1024);
        len=strlen(str);
        p=0,flag=0;
        for(i=0; i<len; i++)
        {
            if(str[i]!= )
            {
                s[p++]=str[i];
            }
            else
            {
                if(flag==1)
                {
                    printf(" ");
                }
                for(j=p-1; j>=0; j--)
                {
                    printf("%c",s[j]);
                }
                flag=1;
                p=0;
            }
        }
        printf(" ");  
        for(i=p-1; i>=0; i--)
        {
            printf("%c",s[i]);  
        }
        printf("\n");
    }
    return 0;
}
View Code

 

CDZSC_2015寒假新人(1)——基础 G

标签:

原文地址:http://www.cnblogs.com/Wing0624/p/4243833.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!