码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3723 Conscription

时间:2015-01-23 13:15:11      阅读:145      评论:0      收藏:0      [点我收藏+]

标签:

Conscription

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

Source

 
 
 
思想: 这儿用到并查集的目的是判断2个士兵是已征收还是未征收。
 
Source Code:
#include <cstdio>
#include <algorithm>

using namespace std;

struct Relationship{
    int girl;
    int boy;
    int cost;
};

Relationship RelArr[50010];
int Root[20010];
int testCount,N,M,R;

void initRoot(int length){
    for(int i=0;i<length;++i)
        Root[i]=-1;
}

bool cmp(Relationship a,Relationship b){
    return a.cost>=b.cost;
}

int findRoot(int x){
    if(Root[x]==-1)
        return x;
    else{
        int tmp=findRoot(Root[x]);
        Root[x]=tmp;
        return tmp;
    }
}

int Kruskal(int answer){
    for(int i=0;i<R;++i){
        int Root_girl=findRoot(RelArr[i].girl);
        int Root_boy=findRoot(RelArr[i].boy);
        if(Root_girl!=Root_boy){
            Root[Root_girl]=Root_boy;
            answer-=RelArr[i].cost;
        }
    }
    return answer;
}

int main(){
    while(scanf("%d",&testCount)!=EOF){
        while(testCount--){
            scanf("%d%d%d",&N,&M,&R);
            initRoot(N+M);
            int tmpGirl,tmpBoy,tmpCost;
            for(int i=0;i<R;++i){
                scanf("%d%d%d",&tmpGirl,&tmpBoy,&tmpCost);
                RelArr[i].girl=tmpGirl;
                RelArr[i].boy=N+tmpBoy;
                RelArr[i].cost=tmpCost;
            }
            sort(RelArr,RelArr+R,cmp);
            int answer=(N+M)*10000;
            answer=Kruskal(answer);
            printf("%d\n",answer);
        }
    }
    return 0;
}

 

 

POJ 3723 Conscription

标签:

原文地址:http://www.cnblogs.com/Murcielago/p/4243784.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!