码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1837 Balance 背包dp

时间:2015-01-23 16:30:49      阅读:173      评论:0      收藏:0      [点我收藏+]

标签:


Balance
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 11067   Accepted: 6865

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm‘s length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
? the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
? the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: ‘-‘ for the left arm and ‘+‘ for the right arm); 
? on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights‘ values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

Source


有一个天平上面有c个挂钩,给你每个挂钩距离天平中心的距离。然后给你g个砝码的重量,求将所有砝码挂到挂钩上使得天平平衡的情况数。
设dp[i][j]=num表示挂第i件物品时,平衡度为j的情况数是num。平衡度为0,说明达到平衡。如果挂到最远端,平衡度最大为15*20*25=7500,为了避免下标出现负数,可以使得7500为平衡点,开一个dp[27][15000]的数组。
dp[i][j]肯定可以由上一个状态dp[i-1][j]得到,可以得到状态转移方程dp[i][j+w[i]*c[k]]+=dp[i-1][j];
一开始任何物品都不挂的话,会达到平衡,初始化dp[0][7500]=1(因为下标*2,所以7500相当于原点位置)。
最近做动态规划一点心得:关键是考虑当前状态和上个状态之间的联系,然后找准状态转移方程就ok了。
//1716K	32MS
#include<stdio.h>
#include<string.h>
int arm[27],hook[27];
int dp[27][15007];
int main()
{
    int c,g;
    while(scanf("%d%d",&c,&g)!=EOF)
    {
        for(int i=1;i<=c;i++)scanf("%d",&arm[i]);
        for(int i=1;i<=g;i++)scanf("%d",&hook[i]);
        memset(dp,0,sizeof(dp));
        dp[0][7500]=1;
        for(int i=1;i<=g;i++)//挂钩
            for(int j=0;j<=15000;j++)//平衡量
                if(dp[i-1][j])
                    for(int k=1;k<=c;k++)//天平
                        dp[i][j+hook[i]*arm[k]]+=dp[i-1][j];
        printf("%d\n",dp[g][7500]);
    }
    return 0;
}


POJ 1837 Balance 背包dp

标签:

原文地址:http://blog.csdn.net/crescent__moon/article/details/43055613

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!