码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1443 Joseph (约瑟夫环)

时间:2015-01-23 18:25:10      阅读:145      评论:0      收藏:0      [点我收藏+]

标签:

Joseph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1741    Accepted Submission(s): 1076


Problem Description
The Joseph‘s problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy. 
 

Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14. 
 

Output
The output file will consist of separate lines containing m corresponding to k in the input file. 
 

Sample Input
3 4 0
 

Sample Output
5 30
 

Source



题意:有2k个人,前面k个是好人,后面k个是坏人。现在他们站成一圈,从第一个人从1开始报数,报到m的人就会被杀掉,剩下的继续接着从1开始报数。问欲使在所有坏人被杀完前没有好人被杀害的最小的m值。


解析:直接从k+1开始枚举m的值,然后对应每个m值,看是否满足要求。




AC代码:

#include<stdio.h>

int ans[14]={0};

int joseph(int k)
{
    int cnt,p;
    if(ans[k]) return ans[k];
    for(int i=k+1;;i++)
    {
        for(cnt=2*k,p=0; cnt>k; cnt--)        //检查是否满足要求
        {
            p = (p + i - 1) % cnt;            //被杀掉的人的位置
            if(p < k) cnt = 0;                //被杀掉的人是前k个(好人)
        }
        if(cnt == k)                          //所有坏人都被杀了,满足要求
        {
            ans[k] = i;
            return i;
        }
    }
    return 0;
}

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF && n)
    {
        printf("%d\n",joseph(n));
    }
    return 0;
}







hdu 1443 Joseph (约瑟夫环)

标签:

原文地址:http://blog.csdn.net/u013446688/article/details/43058247

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!