码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1372 Knight Moves

时间:2015-01-23 21:20:32      阅读:192      评论:0      收藏:0      [点我收藏+]

标签:

Knight Moves

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7261    Accepted Submission(s): 4353

Problem Description
A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part. 

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b. 
 
Input
The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard. 
 
Output
For each test case, print one line saying "To get from xx to yy takes n knight moves.". 
 
Sample Input
e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6  f6
 
Sample Output
To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6  to f6 takes 0 knight moves.
 
Source
 
 
Source Code:
#include <iostream>
#include <string>
#include <queue>
#include <map>

using namespace std;

struct Location{
    int x;
    int y;
    int count;
};

int go[][2]={
    {1,2},
    {2,1},
    {2,-1},
    {1,-2},
    {-1,-2},
    {-2,-1},
    {-2,1},
    {-1,2}
};

map<char,int> Dictionary;
Location start,end;
queue<Location> Q;

void initDictionary(){
    Dictionary.insert(make_pair(a,1));
    Dictionary.insert(make_pair(b,2));
    Dictionary.insert(make_pair(c,3));
    Dictionary.insert(make_pair(d,4));
    Dictionary.insert(make_pair(e,5));
    Dictionary.insert(make_pair(f,6));
    Dictionary.insert(make_pair(g,7));
    Dictionary.insert(make_pair(h,8));
}

int BFS(int end_x,int end_y){
    while(Q.empty()==false){
        int now_x=Q.front().x;
        int now_y=Q.front().y;
        int now_count=Q.front().count+1;
        if(now_x==end_x&&now_y==end_y)
            return 0;
        Q.pop();
        for(int i=0;i<8;++i){
            int new_x=now_x+go[i][0];
            int new_y=now_y+go[i][1];
            if(new_x<1||new_x>8||new_y<1||new_y>8)
                continue;
            if(new_x==end_x&&new_y==end_y){
                return now_count;
            }
            Location tmp;
            tmp.x=new_x;
            tmp.y=new_y;
            tmp.count=now_count;
            Q.push(tmp);
        }
    }
}

int main(){
    string str_a,str_b;
    initDictionary();
    while(cin>>str_a>>str_b){
        start.x=(int)(str_a[1]-0);
        start.y=Dictionary[str_a[0]];
        start.count=0;
        end.x=(int)(str_b[1]-0);
        end.y=Dictionary[str_b[0]];
        while(Q.empty()==false)
            Q.pop();
        Location tmp;
        tmp.x=start.x;
        tmp.y=start.y;
        tmp.count=0;
        Q.push(tmp);
        int answer=BFS(end.x,end.y);
        cout<<"To get from "<<str_a<<" to "<<str_b<< " takes "<<answer<<" knight moves."<<endl;
    }
    return 0;
}

 

HDU 1372 Knight Moves

标签:

原文地址:http://www.cnblogs.com/Murcielago/p/4245041.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!