码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 1312 Red and Black

时间:2015-01-24 11:38:08      阅读:180      评论:0      收藏:0      [点我收藏+]

标签:深搜   递归   

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1312



Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10724    Accepted Submission(s): 6716


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.‘ - a black tile 
‘#‘ - a red tile 
‘@‘ - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
45 59 6 13
 

Source

题意:  在一个图中给出起点以及障碍物,求从该点出发所能到达的点的个数。

题解: 简单深搜,都不用任何剪枝——走过的点标记一下就好~~ 直接递归

AC代码:

#include<iostream>
#define maxn 25
using namespace std;
char chess[maxn][maxn],ch;
int sx,sy,w,h;
int dfs(int x,int y){
    int sum=0;
    if(x<0||x>=h||y<0||y>=w||chess[x][y]=='#')return 0;
    chess[x][y]='#';
   return 1+dfs(x+1,y)+dfs(x,y+1)+dfs(x-1,y)+dfs(x,y-1);
}
int main()
{
    while(cin>>w>>h&&(w||h))
    {
        for(int i=0;i<h;i++)
            for(int j=0;j<w;j++){
                cin>>ch; chess[i][j]=ch;
                if(ch=='@'){
                    chess[i][j]='.'; sx=i; sy=j;
                }
            }
        cout<<dfs(sx,sy)<<endl;
    }
}






HDOJ 1312 Red and Black

标签:深搜   递归   

原文地址:http://blog.csdn.net/mummyding/article/details/43083989

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!