码迷,mamicode.com
首页 > 其他好文 > 详细

UVALive 3029 City Game 悬线法求最大子矩阵面积 dp

时间:2015-01-24 20:06:06      阅读:160      评论:0      收藏:0      [点我收藏+]

标签:

题目链接:点击打开链接

Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees, factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems ? he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

Each area has its width and length. The area is divided into a grid of equal square units. The rent paid for each unit on which you‘re building stands is 3$.

Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N. The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.

Input 

The first line of the input file contains an integer K ? determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units, separated by a blank space. The symbols used are:
R ? reserved unit
F ? free unit
In the end of each area description there is a separating line.

Output 

For each data set in the input file print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.

Sample Input 

2
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F

5 5
R R R R R
R R R R R
R R R R R
R R R R R
R R R R R

Sample Output 

45
0
题意:求全由F构成的最大的矩阵面积(答案*3后输出)

思路:求每个点 能往上延展的最大高度,按此高度往左和往右延展的最大距离。

import java.io.PrintWriter;
import java.util.ArrayList;
import java.util.Arrays;
import java.util.Collections;
import java.util.Comparator;
import java.util.Iterator;
import java.util.LinkedList;
import java.util.PriorityQueue;
import java.util.Scanner;
import java.util.TreeSet;
import java.util.Queue;

public class Main {
	static int N = 1010;
	int n, m;	
	boolean[][] mp = new boolean[N][N];
	int[][] up = new int[N][N], left = new int[N][N], right = new int[N][N];
	void init(){
		n = cin.nextInt();	m = cin.nextInt();
		for(int i = 1; i <= n; i++){
			for(int j = 1; j <= m; j++)
			{
				String s = cin.next();
				mp[i][j] = s.charAt(0)=='R';
			}
		}
	}
	void work() {
		int T = cin.nextInt();
		while(T-- > 0) {
			init();
			for(int i = 1; i <= n; i++)
			{
				left[i][0] = up[i][0] = 0;
				for(int j = 1; j <= m; j++)
				{
					if(mp[i][j])
					{
						left[i][j] = up[i][j] = 0;
					}
					else
					{
						up[i][j] = up[i-1][j]+1;
						left[i][j] = 1;
						if(up[i][j]<=up[i][j-1])
							left[i][j] = left[i][j-1]+1;
					}
				}
				right[i][m+1] = up[i][m+1] = 0;
				for(int j = m; j >= 1; j--)
				{
					if(mp[i][j])
						right[i][j] = 0;
					else
					{
						right[i][j] = 1;
						if(up[i][j]<=up[i][j+1])
							right[i][j] = right[i][j+1]+1;
					}
				}
			}			
			int ans = 0;
			for(int i = 1; i <= n; i++)
				for(int j = 1; j <= m; j++)
					ans = max(ans, up[i][j]*(left[i][j]+right[i][j]-1));
			out.println(ans*3);
		}
	}	

	Main() {
		cin = new Scanner(System.in);
		out = new PrintWriter(System.out);
	}

	public static void main(String[] args) {
		Main e = new Main();
		e.work();
		out.close();
	}
	public Scanner cin;
	public static PrintWriter out;
	
	int max(int x, int y) {
		return x > y ? x : y;
	}
}


UVALive 3029 City Game 悬线法求最大子矩阵面积 dp

标签:

原文地址:http://blog.csdn.net/qq574857122/article/details/43088105

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!