码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3071 Football DP

时间:2015-01-25 11:09:40      阅读:155      评论:0      收藏:0      [点我收藏+]

标签:poj   c++   

Football
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3297   Accepted: 1687

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 ? pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number ?1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2


#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdio>
using namespace std;

#define M (1<<7)+20
double p[M][M];
double dp[8][M];

int main(){
    int n;
    while(~scanf("%d",&n)){
        if(n==-1)   break;
        int i,j,k,t;
        int m=1<<n;
        for(i=0;i<m;i++)
            for(j=0;j<m;j++)
                scanf("%lf",&p[i][j]);

        memset(dp,0,sizeof dp);
        for(i=0;i<=m;i++)  dp[0][i]=1;
        for(i=1;i<=n;i++)
            for(j=0;j<m;j++){
                t=j/(1<<(i-1));
                t^=1;
                dp[i][j]=0;
                for(k=t*(1<<(i-1));k<t*(1<<(i-1))+(1<<(i-1));k++)
                    dp[i][j]+=dp[i-1][j]*dp[i-1][k]*p[j][k];
            }

        int ans;
        double tmp=0;
        for(i=0;i<m;i++){
            if(tmp<dp[n][i]){
                tmp=dp[n][i];
                ans=i;
            }
        }

        printf("%d\n",ans+1);
    }
    return 0;
}











poj 3071 Football DP

标签:poj   c++   

原文地址:http://blog.csdn.net/hyccfy/article/details/43112521

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!