码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1022

时间:2015-01-25 12:34:11      阅读:267      评论:0      收藏:0      [点我收藏+]

标签:acm算法   amp   c   math.h   printf   

Train Problem I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22970    Accepted Submission(s): 8659


Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can‘t leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
技术分享技术分享技术分享
 

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 

Output
The output contains a string "No." if you can‘t exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 

Sample Input
3 123 321 3 123 312
 

Sample Output
Yes. in in in out out out FINISH No. FINISH
Hint
Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can‘t let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".
 

Author
Ignatius.L

 

给你一些火车,以数字来进行标号,判断以一的方式进站,是否能以二的方式出站。假如1 2 3 进站 则可以 3 2 1 出站。 假如1 3 2 进站 也可以 1 2 3出站,因为1进去后可以先出来。然后 2 3 进。 3 2 出。栈主要就是先进后出的思想。

上代码、

 

#include <stdio.h>
#include <stack>
#include <string.h>
#include <algorithm>
using namespace std;
int main()
{
    int i,j,wbx;
    int vis[500];
    char s1[1000];
    char s2[1000];
    stack<char>s;  //将char 类型的放进队列。
    int t;
    while(~scanf("%d%s%s",&t,s1,s2))
    {
        i=j=wbx=0;
        while(!s.empty())  
            s.pop();   //   清空栈。
        while(i<t)
        {
            s.push(s1[i++]);   //    开始进站。
                vis[wbx++]=1;  //    将进站的in存入数组,令为一。
            while(!s.empty() &&s.top()==s2[j])//   如果栈不空的话,并且栈首元素等于出站元素。则弹栈。
            {
                j++;
                vis[wbx++]=0;//  出站的out也存入数组,令为0。
                s.pop();//  弹栈。
            }
        }
        if(!s.empty())
            printf("No.\n");//   上面做好之后,如果此时栈还不是空的,则不能以方式2的顺序出站。
        else //反之可以。
        {
            printf("Yes.\n");
            for(i=0;i<wbx;i++)
            {
                if(vis[i])
                    printf("in\n");
                else
                    printf("out\n");
            }
        }
        printf("FINISH\n");//  完成
    }
    return 0;
}


 

HDU 1022

标签:acm算法   amp   c   math.h   printf   

原文地址:http://blog.csdn.net/sky_miange/article/details/43112859

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!