码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 1610 Count the Colors(线段树,区间覆盖,单点查询)

时间:2015-01-25 15:03:33      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:

Count the Colors

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can see at last.


Input

The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.


Output

Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

If some color can‘t be seen, you shouldn‘t print it.

Print a blank line after every dataset.


Sample Input

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1


Sample Output

1 1
2 1
3 1

1 1

0 2
1 1

 

用col[rt]记录区间的颜色,-1表示多个颜色。。。

技术分享
#include <bits/stdc++.h>
using namespace std;
#define root 1,n,1
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
#define lr rt<<1
#define rr rt<<1|1
const int N =  20010;
int n , m , col[N<<2],tag[N<<2] ;

void Down( int l , int r , int rt ) {
    if( col[rt] != -1 ) col[lr] = col[rr] = col[rt] ;
}
void Up( int rt ){
    if( col[lr] == col[rr] ) col[rt] = col[lr];
    else col[rt] = -1 ;
}
void build( int l , int r , int rt ){
    col[rt] = -1 ;
    if( l == r ) return ;
    int mid = (l+r)>>1;
    build(lson),build(rson);
}
void update( int l , int r , int rt , int L , int R , int c ) {
    if( L == l && r == R ) {
        col[rt] = c ; return ;
    }
    if( col[rt] == c ) return ;
    else Down( l,r,rt ) , col[rt] = -1 ;
    int mid = (l+r)>>1;
    if( R <= mid ) update(lson,L,R,c);
    else if( L > mid ) update(rson,L,R,c);
    else update(lson,L,mid,c) , update(rson,mid+1,R,c);
    Up(rt);
}

int query( int l , int r , int rt , int x ) {
    if( col[rt] != -1 || l == r ) return col[rt];
    Down(l,r,rt);
    int mid = (l+r)>>1;
    if( x <= mid ) return query(lson,x);
    else return query(rson,x);
}

int main()
{
    int _ ,x ,y , c ;
    n = 8888;
    while( ~scanf("%d",&m) ) {
        memset( tag , 0, sizeof tag );
        build(root);
        while( m-- ) {
            scanf("%d%d%d",&x,&y,&c);x++;
            update(root,x,y,c);
        }
        int last = -1 , now ;
        for( int i = 1 ; i <= n ; ++i ) {
            now = query(root,i);
            if( last == -1 ) { last = now ; continue ; }
            if( last == now ) continue ;
            else tag[last]++; last=now;
        }
        for( int i = 0 ; i <= n ; ++i ) if( tag[i] ){
            printf("%d %d\n",i,tag[i]);
        }printf("\n");
    }
}
View Code

 

ZOJ 1610 Count the Colors(线段树,区间覆盖,单点查询)

标签:

原文地址:http://www.cnblogs.com/hlmark/p/4248171.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!