码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1836 Alignment 枚举中间点双向求LIS

时间:2015-01-25 16:44:36      阅读:194      评论:0      收藏:0      [点我收藏+]

标签:


Alignment
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 13590   Accepted: 4375

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line‘s extremity (left or right). A soldier see an extremity if there isn‘t any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 
? 2 <= n <= 1000 
? the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

Source



一排士兵按照标号站成一排,让一些士兵出列,使得剩下的士兵朝左或者朝右看都能看到无穷远处。
where each soldier can see by looking lengthwise the line at least one of the line‘s extremity (left or right).士兵能够朝着至少一个方向看到无穷远处。
新队列的身高要满足这个式子:tail[1]<tail[2]<.....tail[i]  tail[i+1]>tail[i+2]>......tail[n]
把从1枚举到n-1,分别求出1到i的最长上升子序列和i+1到n的最长下降子序列,最后用n减去他们的最大和。
//172K	297MS
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
double tail[1007],dp[1007],s[1007];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int maxx=-1;
        for(int i=1;i<=n;i++)
            scanf("%lf",&tail[i]);

        memset(dp,0,sizeof(dp));
        for(int i=1;i<n;i++)//枚举中间点
        {
            //求1到i的最长上升子序列
            dp[1]=tail[1];
            int low,high,mid,len=1;
            for(int j=2;j<=i;j++)
            {
                low=1;high=len;
                while(low<=high)
                {
                    mid=(low+high)>>1;
                    if(dp[mid]<tail[j])low=mid+1;
                    else high=mid-1;
                }
                dp[low]=tail[j];
                if(low>len)len++;
            }

            //求i+1到n的最长下降子序列
            memset(dp,0,sizeof(dp));
            memset(s,0,sizeof(s));
            int k=0,len2=1;
            for(int j=n;j>i;j--)//倒序一下
                s[++k]=tail[j];
            dp[1]=s[1];
            for(int j=2;j<=k;j++)//倒着求最长上升子序列
            {
                low=1;high=len2;
                while(low<=high)
                {
                    mid=(low+high)>>1;
                    if(dp[mid]<s[j])low=mid+1;
                    else high=mid-1;
                }
                dp[low]=s[j];
                if(low>len2)len2++;
            }
            if(len+len2>maxx)maxx=len+len2;
        }
        printf("%d\n",n-maxx);
    }
    return 0;
}


POJ 1836 Alignment 枚举中间点双向求LIS

标签:

原文地址:http://blog.csdn.net/crescent__moon/article/details/43115059

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!