码迷,mamicode.com
首页 > 其他好文 > 详细

(Dinic) hdu 3549

时间:2015-01-26 01:15:45      阅读:120      评论:0      收藏:0      [点我收藏+]

标签:

Flow Problem

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 8864    Accepted Submission(s): 4170


Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

 

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

 

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 

 

Sample Input
2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
 

 

Sample Output
Case 1: 1 Case 2: 2
 

 

Author
HyperHexagon
 

 

Source
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<queue>
using namespace std;
#define INF 0x7fffffff
queue<int> q;
int tab[250][250];
int dis[250];
int N,M,ANS;
int BFS()
{
     memset(dis,-1,sizeof(dis));
     dis[1]=0;
     q.push(1);
     while (!q.empty())
     {
           int x=q.front();
           q.pop();
           for (int i=1;i<=N;i++)
               if (dis[i]<0&&tab[x][i]>0)
               {
                  dis[i]=dis[x]+1;
                  q.push(i);
               }
     }
     if(dis[N]>0)
        return 1;
     else
        return 0;
}
int find(int x,int low)
{
    int a=0;
    if (x==N)return low;
    for (int i=1;i<=N;i++)
    if (tab[x][i]>0&&dis[i]==dis[x]+1&&(a=find(i,min(low,tab[x][i]))))
    {
       tab[x][i]-=a;
       tab[i][x]+=a;
       return a;
    }
    return 0;
}
int main()
{
    int tt,f,t,flow,tans,cas=1;
    scanf("%d",&tt);
    while(tt--)
    {
            scanf("%d%d",&N,&M);
            memset(tab,0,sizeof(tab));
            for(int i=1;i<=M;i++)
            {
                  scanf("%d%d%d",&f,&t,&flow);
                  tab[f][t]+=flow;
            }
            ANS=0;
            while(BFS())
            {
                  while(tans=find(1,INF))ANS+=tans;
            }
            printf("Case %d: %d\n",cas,ANS);
            cas++;
    }
    return 0;
}

  

(Dinic) hdu 3549

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4249238.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!