码迷,mamicode.com
首页 > 其他好文 > 详细

HDU3117 Fibonacci Numbers 【通项公式】

时间:2015-01-26 17:13:25      阅读:81      评论:0      收藏:0      [点我收藏+]

标签:hdu3117

Fibonacci Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1936    Accepted Submission(s): 759


Problem Description
The Fibonacci sequence is the sequence of numbers such that every element is equal to the sum of the two previous elements, except for the first two elements f0 and f1 which are respectively zero and one.
技术分享

What is the numerical value of the nth Fibonacci number?
 

Input
For each test case, a line will contain an integer i between 0 and 108 inclusively, for which you must compute the ith Fibonacci number fi. Fibonacci numbers get large pretty quickly, so whenever the answer has more than 8 digits, output only the first and last 4 digits of the answer, separating the two parts with an ellipsis (“...”).

There is no special way to denote the end of the of the input, simply stop when the standard input terminates (after the EOF).
 

Sample Input
0 1 2 3 4 5 35 36 37 38 39 40 64 65
 

Sample Output
0 1 1 2 3 5 9227465 14930352 24157817 39088169 63245986 1023...4155 1061...7723 1716...7565

最小的斐波那契9位数是第40个,所以当n<40时直接输出结果。当n>=40时要分成前四位和后四位输出,后四位可以打表,循环节长度是15000(不知道咋证明的),因此打个表存起来,难点在求前四位,可以用斐波那契通项公式F(n)=(1/√5)*{[(1+√5)/2]^n - [(1-√5)/2]^n}【√5表示根号5,f0=0,f1=1】,这里有个坑,若是直接套这个公式将结果存入double中也会造成溢出。。。所以需要化简,但是式子有些复杂又不好化简,好在只需要求前4位,对精度要求不是太高,所以把(1-√5)/2这一项去掉不影响结果,令x=log10(1/sqrt(5)),y=log10((1+sqrt(5))/2);那么log10(fn)=x+n*y;然后就可以用科学计数法来求出前四位。

#include <stdio.h>
#include <math.h>

int fib_4[15010] = {0, 1}, fib[40] = {0, 1};
const double x = log10(1.0 / sqrt(5.0));
const double y = log10((1.0 + sqrt(5.0)) / 2.0);

int main() {
	int n, i, b;
	double a;
	for (i = 2; i < 40; ++i) fib[i] = fib[i-1] + fib[i-2];
	for (i = 2; i <= 15000; ++i) {
		fib_4[i] = fib_4[i-1] + fib_4[i-2];
		if (fib_4[i] >= 10000) fib_4[i] -= 10000;
	}
	while (scanf("%d", &n) == 1) {
		if (n < 40) printf("%d\n", fib[n]);
		else {
			a = x + n * y;
			a -= (int)a;
			a = pow(10, a);
			printf("%d...%0.4d\n", (int)(a * 1000), fib_4[n%15000]);
		}
	}
	return 0;
}


HDU3117 Fibonacci Numbers 【通项公式】

标签:hdu3117

原文地址:http://blog.csdn.net/chang_mu/article/details/43153309

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!