标签:namespace 编程 iostream 数据
Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers
in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1
Sample Output
代码如下:
#include <iostream>
#include <cstdio>
using namespace std;
int gcd(int a, int b);
int main()
{
int n,a,b,m;
while (cin>>n)
{
while (n--)
{
cin>>m>>a;
--m;
while (m--)
{
cin>>b;
a = a / gcd (a, b) * b;
}
cout<<a<<endl;
}
}
return 0;
}
int gcd (int a, int b)
{
int tmp;
while (b != 0)
{
tmp = a;
a = b;
b = tmp % b;
}
return a;
}
运行结果:
YT14-HDU-求多组数的最小公倍数
标签:namespace 编程 iostream 数据
原文地址:http://blog.csdn.net/liuchang54/article/details/43152753