码迷,mamicode.com
首页 > 其他好文 > 详细

uva 10054 The Necklace(欧拉回路)

时间:2015-01-26 19:26:10      阅读:98      评论:0      收藏:0      [点我收藏+]

标签:uva   c++   

                       uva 10054 The Necklace



My little sister had a beautiful necklace made of colorful beads. Two successive beads in the necklace shared a common color at their meeting point. The figure below shows a segment of the necklace:

技术分享

But, alas! One day, the necklace was torn and the beads were all scattered over the floor. My sister did her best to recollect all the beads from the floor, but she is not sure whether she was able to collect all of them. Now, she has come to me for help. She wants to know whether it is possible to make a necklace using all the beads she has in the same way her original necklace was made and if so in which order the bids must be put.

Please help me write a program to solve the problem.

Input 

The input contains T test cases. The first line of the input contains the integer T.

The first line of each test case contains an integer N ( 技术分享) giving the number of beads my sister was able to collect. Each of the next N lines contains two integers describing the colors of a bead. Colors are represented by integers ranging from 1 to 50.

Output 

For each test case in the input first output the test case number as shown in the sample output. Then if you apprehend that some beads may be lost just print the sentence ``some beads may be lost" on a line by itself. Otherwise, print N lines with a single bead description on each line. Each bead description consists of two integers giving the colors of its two ends. For 技术分享, the second integer on line i must be the same as the first integer on line i + 1. Additionally, the second integer on line N must be equal to the first integer on line 1. Since there are many solutions, any one of them is acceptable.

Print a blank line between two successive test cases.

Sample Input 

2
5
1 2
2 3
3 4
4 5
5 6
5
2 1
2 2
3 4
3 1
2 4

Sample Output 

Case #1
some beads may be lost
 
Case #2
2 1
1 3
3 4
4 2
2 2



题目大意:给出一堆珠子,每个珠子有两个颜色,要求判断所给出的珠子是否能连成一个环状的项链。

解题思路:典型的欧拉回路问题,满足:

1、所有点的入度要等于出度;

2、所有点的联通

输出的时候要注意点的自身形成一个环

比如:

1 -> 2

2  -> 3

3 -> 1

2 -> 4

4 -> 2

欧拉回路需要逆序输出。

#include<stdio.h>
#include<string.h>
int gra[550][550], num[550], vis[550], n;
int get(int x) {  
	return num[x] != x ? get(num[x]) : x;
}
void print(int a){ //逆序输出 
	for (int i = 0; i < 55; i++)  
		if (gra[a][i]){  
			gra[a][i]--;  
			gra[i][a]--;  
			print(i);  
			printf("%d %d\n", i , a);  
		}  
}  
int main() {
	int T, cnt = 1;
	scanf("%d", &T);
	while (T--) {
		memset(vis, 0, sizeof(vis));
		memset(gra, 0, sizeof(gra));
		scanf("%d", &n);
		int a, b;
		for (int i = 0; i < 55; i++) {
			num[i] = i;
		}
		for (int i = 0; i < n; i++) {
			scanf("%d %d", &a, &b);	
			vis[a]++;
			vis[b]++; //统计 度
			gra[a][b]++;
			gra[b][a]++; //构建图
			num[get(a)] = get(b); //联通
		}
		int begin = 0;
		for (int i = 0; i < 55; i++) {
			if (vis[i] && get(i) == i) { //若度不为零,且为环的起始点
				begin = i;
				break;
			}
		}
		int flag = 0;
		for (int i = 0; i < 55; i++) {
			flag += vis[i] % 2; 
			if (vis[i] && begin != get(i)) { //不连通
				flag++;
			}
		}
		printf("Case #%d\n", cnt++);
		if (flag) printf("some beads may be lost\n");
		else print(begin);
		if (T) printf("\n");
	}
	return 0;
}



uva 10054 The Necklace(欧拉回路)

标签:uva   c++   

原文地址:http://blog.csdn.net/llx523113241/article/details/43154587

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!