码迷,mamicode.com
首页 > 其他好文 > 详细

杭电acm:大数阶乘(附源码)

时间:2015-01-26 22:54:23      阅读:236      评论:0      收藏:0      [点我收藏+]

标签:杭电   acm   c语言   

Problem Description

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

Input

One N in one line, process to the end of file.

Output

For each N, output N! in one line.

Sample Input

1
2
3

Sample Output

 1
 2
 6
#include <stdio.h>
int main()
{
    int tmp,n,j;
    int a[35661];//10000的阶乘位数为35660
    int d;
    int temp,i;   
    while(scanf("%d",&n)!=EOF){
    a[0]=1;d=1;
    for(i=2; i<=n; i++)
    {
        for(tmp=0,j=1; j<=d; ++j)//大于十进位
        {
            temp=a[j-1]*i+tmp;
            a[j-1]=temp%10;
            tmp=temp/10;
        }
        while(tmp)
        {
            a[++d-1]=tmp%10;
            tmp/=10;
        }
    }
   
    for(int k=d; k>=1; --k)//去掉多余的0
        printf("%d",a[k-1]);
    printf("\n");
 }
    return 0;
}


杭电acm:大数阶乘(附源码)

标签:杭电   acm   c语言   

原文地址:http://blog.csdn.net/qq754406613/article/details/43156703

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!