码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1062 Text Reverse 字符串反转

时间:2015-01-26 22:58:27      阅读:256      评论:0      收藏:0      [点我收藏+]

标签:字符串

Text Reverse


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18240    Accepted Submission(s): 6900




Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
 


Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 


Output
For each test case, you should output the text which is processed.
 


Sample Input
3
olleh !dlrow
m‘I morf .udh
I ekil .mca
 


Sample Output
hello world!
I‘m from hdu.
I like acm.


Hint


Remember to use getchar() to read ‘\n‘ after the interger T, then you may use gets() to read a line and process it.

 


字符串的题目。要注意空格的输出,空格也要原样输出。所以之前用stringstream 打的PE了。


 
#include<stdio.h>
#include<string>
#include<iostream>
#include<sstream>
#include<algorithm>
using namespace std;

int main()
{
	int n;
	stringstream stream;
	string str;
	scanf("%d",&n);
	getchar();
	while(n--)
	{
		getline(cin,str);
		int pos=0;
		for(int i=0;i<str.length();i++)
		{
			if(str[i]!=' '&&(i==0||str[i-1]==' '))
				pos=i;

			if((i+1==str.length()||str[i+1]==' ')&&str[i]!=' ')
			{
				for(int j=pos;j<=(i+pos)/2;j++)
				{
					swap(str[i-(j-pos)],str[j]);
				}
			}

			
		}


		cout<<str<<endl;
	}
	return 0;
}

hdu 1062 Text Reverse 字符串反转

标签:字符串

原文地址:http://blog.csdn.net/u013532224/article/details/43156075

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!