码迷,mamicode.com
首页 > 其他好文 > 详细

uva 575 Skew Binary(数论)

时间:2015-01-26 23:01:06      阅读:373      评论:0      收藏:0      [点我收藏+]

标签:uva

                               uva 575 Skew Binary


When a number is expressed in decimal, the k-th digit represents a multiple of 10k. (Digits are numbered from right to left, where the least significant digit is number 0.) For example,

技术分享

When a number is expressed in binary, the k-th digit represents a multiple of 2k. For example,

技术分享

In skew binary, the k-th digit represents a multiple of 2k+1 - 1. The only possible digits are 0 and 1, except that the least-significant nonzero digit can be a 2. For example,

技术分享

The first 10 numbers in skew binary are 0, 1, 2, 10, 11, 12, 20, 100, 101, and 102. (Skew binary is useful in some applications because it is possible to add 1 with at most one carry. However, this has nothing to do with the current problem.)

Input 

The input file contains one or more lines, each of which contains an integer n. If n = 0 it signals the end of the input, and otherwise n is a nonnegative integer in skew binary.

Output 

For each number, output the decimal equivalent. The decimal value of n will be at most 2 31 - 1 = 2147483647.

Sample Input 

10120
200000000000000000000000000000
10
1000000000000000000000000000000
11
100
11111000001110000101101102000
0

Sample Output 

44
2147483646
3
2147483647
4
7
1041110737


题目大意:根据公式求值。

解题思路:模拟公式。


#include<stdio.h>
#include<string.h>
#include<math.h>
int main() {
	char str[100];
	while (true) {
		memset(str, 0, sizeof(str));
		scanf("%s", str);
		int len = strlen(str);
		if (len == 1 && str[0] == '0') break;
		int sum = 0;
		int two = 2;
		int temp;
		while (len) {
			temp = str[len - 1] - '0';
			sum += (two - 1) * temp;
			two *= 2;
			len--;
		}
		printf("%d\n", sum);
	}	
	return 0;
}


uva 575 Skew Binary(数论)

标签:uva

原文地址:http://blog.csdn.net/llx523113241/article/details/43154947

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!