码迷,mamicode.com
首页 > 其他好文 > 详细

(线段树成段更新+区间求和) poj 3468

时间:2015-01-27 14:51:04      阅读:171      评论:0      收藏:0      [点我收藏+]

标签:

D - A Simple Problem with Integers
Time Limit:5000MS     Memory Limit:131072KB     64bit IO Format:%I64d & %I64u

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C abc" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q ab" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
using namespace std;
#define N 100010
#define LL long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
LL add[N<<2],sum[N<<2];
int n,m;
void pushup(int rt)
{
      sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void build(int l,int r,int rt)
{
      add[rt]=0;
      if(l==r)
      {
            scanf("%I64d",&sum[rt]);
            return ;
      }
      int m=(l+r)>>1;
      build(lson);
      build(rson);
      pushup(rt);
}
void pushdown(int rt,int m)
{
      if(add[rt])
      {
         add[rt<<1]+=add[rt];
         add[rt<<1|1]+=add[rt];
         sum[rt<<1]+=(m-(m>>1))*add[rt];
         sum[rt<<1|1]+=(m>>1)*add[rt];
         add[rt]=0;
      }
}
void update(int L,int R,int c,int l,int r,int rt)
{
      if(L<=l&&r<=R)
      {
           add[rt]+=c;
           sum[rt]+=(LL)(r-l+1)*c;
           return ;
      }
      pushdown(rt,r-l+1);
      int m=(l+r)>>1;
      if(L<=m) update(L,R,c,lson);
      if(m<R) update(L,R,c,rson);
      pushup(rt);
}
LL query(int L,int R,int l,int r,int rt)
{
      if(L<=l&&r<=R)
      {
            return sum[rt];
      }
      pushdown(rt,r-l+1);
      int m=(l+r)>>1;
      LL ret=0;
      if(L<=m) ret+=query(L,R,lson);
      if(m<R) ret+=query(L,R,rson);
      return ret;
}
int main()
{
     scanf("%d%d",&n,&m);
     build(1,n,1);
     while(m--)
     {
           int a,b,c;
           char s[5];
           scanf("%s",s);
           if(s[0]==‘Q‘)
           {
               scanf("%d%d",&a,&b);
               printf("%I64d\n",query(a,b,1,n,1));
           }
           else
           {
                 scanf("%d%d%d",&a,&b,&c);
                 update(a,b,c,1,n,1);
           }
     }
     return 0;
}

  

(线段树成段更新+区间求和) poj 3468

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4252878.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!