码迷,mamicode.com
首页 > 其他好文 > 详细

(线段树 区间最大,单点更新) I Hate It

时间:2015-01-27 17:47:35      阅读:149      评论:0      收藏:0      [点我收藏+]

标签:

B - I Hate It
Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。 
这让很多学生很反感。 

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
 

Input

本题目包含多组测试,请处理到文件结束。 
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。 
学生ID编号分别从1编到N。 
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。 
接下来有M行。每一行有一个字符 C (只取‘Q‘或‘U‘) ,和两个正整数A,B。 
当C为‘Q‘的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。 
当C为‘U‘的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。 
 

Output

对于每一次询问操作,在一行里面输出最高成绩。
 

Sample Input

5 6 1 2 3 4 5 Q 1 5 U 3 6 Q 3 4 Q 4 5 U 2 9 Q 1 5
 

Sample Output

5 6 5 9
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<cstdlib>
using namespace std;
#define N 200010
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define INF 0x7fffffff
int n,m,sum[N<<2],maxx[N<<2],ans;
void pushup(int rt)
{
      maxx[rt]=max(maxx[rt<<1],maxx[rt<<1|1]);
}
void build(int l,int r,int rt)
{
      if(l==r)
      {
            maxx[rt]=sum[l];
            return ;
      }
      int m=(l+r)>>1;
      build(lson);
      build(rson);
      pushup(rt);
}
void query(int L,int R,int l,int r,int rt)
{
      if(L<=l&&r<=R)
      {
          ans=max(maxx[rt],ans);
          return ;
      }
      int m=(l+r)>>1,ret=0;
      if(L<=m) query(L,R,lson);
      if(m<R) query(L,R,rson);
}
void add(int x,int c,int l,int r,int rt)
{
      if(l==x&&r==x)
      {
            maxx[rt]=c;
            return ;
      }
      int m=(l+r)>>1;
      if(x<=m) add(x,c,lson);
      else add(x,c,rson);
      pushup(rt);
}
int main()
{
      while(scanf("%d%d",&n,&m)!=EOF)
      {
            for(int i=1;i<=n;i++)
                  scanf("%d",&sum[i]);
            build(1,n,1);
            char s[5];
            int x,y;
            while(m--)
            {
                  scanf("%s",s);
                  scanf("%d%d",&x,&y);
                  if(s[0]==‘Q‘)
                  {
                        ans=0;
                        query(x,y,1,n,1);
                        printf("%d\n",ans);
                  }
                  else if(s[0]==‘U‘)
                  {
                        add(x,y,1,n,1);
                  }
            }
      }
      return 0;
}

  

(线段树 区间最大,单点更新) I Hate It

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4253319.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!