码迷,mamicode.com
首页 > 其他好文 > 详细

uva 10004 Bicoloring(DFS)

时间:2015-01-27 18:25:17      阅读:145      评论:0      收藏:0      [点我收藏+]

标签:uva   c++   

                                uva 10004 Bicoloring



In 1976 the ``Four Color Map Theorem" was proven with the assistance of acomputer. This theorem states that every map can be colored using only fourcolors, in such a way that no region is colored using the same color as aneighbor region.

Here you are asked to solve a simpler similar problem. Youhave to decide whether a given arbitrary connected graph can be bicolored.That is, if one can assign colors (from a palette of two) to the nodes in sucha way that no two adjacent nodes have the same color. To simplify the problemyou can assume:

  • no node will have an edge to itself.
  • the graph is nondirected. That is, if a node a is said to be connectedto a node b, then you must assume that b is connected to a.
  • the graph will be strongly connected. That is, there will be at leastone path from any node to any other node.

Input 

The input consists of several test cases. Each test casestarts with a line containing the number n (1 < n < 200) of differentnodes. The second line contains the number of edges l. After this, l lineswill follow, each containing two numbers that specify an edge between the twonodes that they represent. A node in the graph will be labeled using a numbera (技术分享).

An input with n = 0 will mark the end of the input and isnot to be processed.

Output 

You have to decide whether the input graph can bebicolored or not, and print it as shown below.

Sample Input 

3
3
0 1
1 2
2 0
9
8
0 1
0 2
0 3
0 4
0 5
0 6
0 7
0 8
0

Sample Output 

NOT BICOLORABLE.
BICOLORABLE.



题目大意:二染色。

条件:

1、不存在环

2、图是连通图

3、双向图

解题思路(转):

任意取一个点进行染色,如果发现要涂某一块时这个块已经被涂了色,并且与我们要使用的颜色不同的话,就说明这个图不能被染成BICOLORABLE的。
(1)如果没有染色,将它染色,并将它周围的点变成相反色。

(2)如果已经染色,判断是否与现在染色的点的颜色相同,相同,则退出,否则继续。



#include<stdio.h>
#include<string.h>
int G[205][205], vis[205], color[205];
int m, n;
int DFS(int a) {
	for (int i = 0; i < m; i++) {
		if (G[a][i]) {
			if (!vis[i]) {
				vis[i] = 1;
				color[i] = !color[a];
				DFS(i);
			}
			else if (color[i] == color[a]) return 0;
		}
	}
	return 1;
}
int main() {
	while (scanf("%d\n%d", &m, &n) == 2) {
		memset(G, 0, sizeof(G));
		memset(vis, 0, sizeof(vis));
		int a, b;
		for (int i = 0; i < n; i++) {
			scanf("%d %d\n", &a, &b);
			G[a][b] = G[b][a] = 1;
		}
		color[0] = 1;
		vis[0] = 1;
		if (DFS(0)) printf("BICOLORABLE.\n");
		else printf("NOT BICOLORABLE.\n");
	}
	return 0;
}


uva 10004 Bicoloring(DFS)

标签:uva   c++   

原文地址:http://blog.csdn.net/llx523113241/article/details/43197551

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!