码迷,mamicode.com
首页 > 其他好文 > 详细

(模拟) zoj 1610

时间:2015-01-28 00:47:44      阅读:206      评论:0      收藏:0      [点我收藏+]

标签:

F - Count the Colors
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu
Submit Status

Description

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can see at last.

 

Input



The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

 

Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.

 

Output



Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

 

If some color can‘t be seen, you shouldn‘t print it.

Print a blank line after every dataset.

 

Sample Input



5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1

 

 

Sample Output



1 1
2 1
3 1

 

1 1

0 2
1 1

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<cstdlib>
using namespace std;
#define N 8001
int n,color[N],cnt[N];
int main()
{
      while(scanf("%d",&n)!=EOF)
      {
            int x,y,z,i,j,maxx=0;
            memset(color,0,sizeof(color));
            memset(cnt,0,sizeof(cnt));
            for(i=0;i<n;i++)
            {
                  scanf("%d%d%d",&x,&y,&z);
                  for(j=x;j<y;j++)
                        color[j]=z+1;
                  if(maxx<y)
                        maxx=y;
            }
            for(i=0;i<maxx;i++)
            {
                  while(i!=0&&color[i]&&color[i]==color[i-1])
                        i++;
                  if(color[i])
                        cnt[color[i]-1]++;
            }
            for(int i=0;i<=N;i++)
                  if(cnt[i])
                  {
                        printf("%d %d\n",i,cnt[i]);
                  }
            printf("\n");
      }
      return 0;
}

  

(模拟) zoj 1610

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4254704.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!