码迷,mamicode.com
首页 > 其他好文 > 详细

(模拟) hdu 1698

时间:2015-01-28 00:53:56      阅读:196      评论:0      收藏:0      [点我收藏+]

标签:

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18763    Accepted Submission(s): 9415


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

技术分享


Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

 

Sample Input
1 10 2 1 5 2 5 9 3
 

 

Sample Output
Case 1: The total value of the hook is 24.
 

 

Source
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<cstdlib>
using namespace std;
int tt,n,m,a[100005][3];
int main()
{
      scanf("%d",&tt);
      for(int k=1;k<=tt;k++)
      {
            int sum=0;
            scanf("%d%d",&n,&m);
            for(int i=1;i<=m;i++)
                  scanf("%d%d%d",&a[i][0],&a[i][1],&a[i][2]);
            for(int i=1;i<=n;i++)
            {
                  int v=1;
                  for(int j=m;j>=1;j--)
                  {
                        if(a[j][0]<=i&&a[j][1]>=i)
                        {
                              v=a[j][2];
                              break;
                        }
                  }
                  sum+=v;
            }
            printf("Case %d: The total value of the hook is %d.\n",k,sum);
      }
      return 0;
}

  

(模拟) hdu 1698

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4254642.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!