标签:c++ iostream namespace 博客 数据
Problem Description
An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting
then repeats. How long before the worm climbs out of the well? We‘ll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we‘ll assume the worm makes it out.
Input
There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end
of output.
Output
Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.
Sample Input
Sample Output
代码如下:
#include <iostream>
using namespace std;
int main()
{
int n,u,d;
while(cin>>n>>u>>d)
{
if(n==0&&u==0&&d==0)
break;
else
{
if(((n-u)%(u-d))==0)
cout<<1+2*((n-u)/(u-d))<<endl;
else
cout<<1+2*(((n-u)/(u-d))+1)<<endl;
}
}
return 0;
}
YT14-先来练练手之爬动的蠕虫
标签:c++ iostream namespace 博客 数据
原文地址:http://blog.csdn.net/liuchang54/article/details/43202437