码迷,mamicode.com
首页 > 其他好文 > 详细

YT14-先来练练手之电梯RUNTIME

时间:2015-01-28 09:55:48      阅读:148      评论:0      收藏:0      [点我收藏+]

标签:c++   iostream   namespace   博客   数据   

Problem Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output

Print the total time on a single line for each test case. 

Sample Input

1 2
3 2 3 1
0

Sample Output

17
41

代码如下:

#include <iostream>  
using namespace std;  
int main()  
{  
    int n;  
    while(cin>>n&&n!=0)  
    {  
        int a[n],i,sum=0;  
        if(n==1)  
        {  
            cin>>a[0];  
            cout<<(a[0]*6)+5<<endl;  
        }  
        else  
        {  
            for(i=0; i<n; ++i)  
                cin>>a[i];  
            sum+=(a[0]*6+5);  
            for(i=1; i<n; ++i)  
            {  
                if(a[i]>a[i-1])  
                    sum+=(5+(a[i]- a[i-1])*6);  
                else  
                    sum+=(5+(a[i-1]- a[i])*4);  
            }  
            cout<<sum<<endl;  
        }  
    }  
    return 0;  
}  




YT14-先来练练手之电梯RUNTIME

标签:c++   iostream   namespace   博客   数据   

原文地址:http://blog.csdn.net/liuchang54/article/details/43202111

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!