码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1874 畅通工程续 Dijkstra

时间:2015-01-28 14:28:33      阅读:149      评论:0      收藏:0      [点我收藏+]

标签:

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1874

题目分析:输入起点和终点,顶点的个数,已连通的边。 输出起点到终点的最短路径,若不存在,输出-1。

注意事项:1.可能有多条路径  2.要判断不存在连通路径的情况 

/*畅通工程续

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 31092    Accepted Submission(s): 11348


Problem Description
某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。
 

Input
本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。
 

Output
对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.
 

Sample Input
3 3
0 1 1
0 2 3
1 2 1
0 2
3 1
0 1 1
1 2
 

Sample Output
2
-1
 

Author
linle
 
*/
#include <cstdio>
#include <cstring>
#define INF 0xfffff 
const int maxn = 200 + 10;
int w[maxn][maxn], d[maxn], v[maxn], n, m, s, t;

int Min(int a, int b)
{
    return a < b ? a : b;
}

void dijkstra()
{
    memset(v, 0, sizeof(v));
    for(int i = 0; i < n; i++) d[i] = (i==s ? 0 : INF);
     for(int i = 0; i < n; i++){
         int x, l =INF;
         for(int y = 0; y < n; y++) if(!v[y] && d[y] <= l) l = d[x=y];
        if(l == INF) break;
        v[x] = 1;
        for(int y = 0; y < n; y++) d[y] = Min(d[y], d[x]+w[x][y]);
     }
} 

int main()
{
    int a, b, c;
    while(~scanf("%d%d", &n, &m)){
        for(int i = 0; i < n; i++)
            for(int j = 0; j < n; j++)
                w[i][j] = INF;
        for(int i = 0; i < m; i++){
            scanf("%d%d%d", &a, &b, &c);
            w[a][b] = w[b][a] = (w[a][b] > c ? c : w[a][b]);
        }
        scanf("%d%d", &s, &t);
        dijkstra();
        if(d[t] == INF) printf("-1\n");
        else printf("%d\n", d[t]);
    }
    return 0;
}

 

hdu 1874 畅通工程续 Dijkstra

标签:

原文地址:http://www.cnblogs.com/ACFLOOD/p/4255538.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!