码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3176-Cow Bowling(dp_数字三角形)

时间:2015-01-28 16:07:49      阅读:148      评论:0      收藏:0      [点我收藏+]

标签:

Cow Bowling
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

The cows don‘t use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 

          7 

 3   8 

 8   1   0 

 2   7   4   4 

 4   5   2   6   5
Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow‘s score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame. 

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample: 

          7 
         *

 3   8 
       *

 8   1   0 
       *

 2   7   4   4 
       *

 4   5   2   6   5
The highest score is achievable by traversing the cows as shown above.

题意:输入一个n层的三角形,第i层有i个数,求从第1层到第n层的所有路线中,权值之和最大的路线。
规定:第i层的某个数只能连线走到第i+1层中与它位置相邻的两个数中的一个。

思路:这是典型的动态规划里面的数字三角形的问题。dp[i][j]表示以第i行j列的位置作为终点的路线的最大权值。那么dp[i][j]的最大值取决于dp[i-1][j-1]和dp[i-1][j],从这两者之间筛选出最大值,加到dp[i][j]上,即为dp[i][j]的最大权值。我用的方法是倒着向上加,每次都加的是该相邻两个的最大值,那么到最后dp[0][0]为最大值。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <set>
#include <queue>

using namespace std;
const int inf=0x3f3f3f3f;
int a[410][410];
int dp[410][410];
int main()
{
    int n,m,i,j;
    scanf("%d",&n);
    memset(dp,0,sizeof(dp));
    for(i=0;i<n;i++){
        for(j=0;j<=i;j++)
            scanf("%d",&a[i][j]);
    }
    for(i=0;i<n;i++)
        dp[n-1][i]=a[n-1][i];
    for(i=n-2;i>=0;i--)
        for(j=0;j<=i;j++)
            dp[i][j]=a[i][j]+max(dp[i+1][j],dp[i+1][j+1]);
    printf("%d\n",dp[0][0]);
    return 0;
}


POJ 3176-Cow Bowling(dp_数字三角形)

标签:

原文地址:http://blog.csdn.net/u013486414/article/details/43230255

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!