码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 2988 Conversions(数学啊)

时间:2015-01-28 19:49:26      阅读:211      评论:0      收藏:0      [点我收藏+]

标签:数学   zoj   

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=1987


Conversion between the metric and English measurement systems is relatively simple. Often, it involves either multiplying or dividing by a constant. You must write a program that converts between the following units:

Type Metric English equivalent
Weight 1.000 kilograms 2.2046 pounds
Weight 0.4536 kilograms 1.0000 pound
Volume 1.0000 liter 0.2642 gallons
Volume 3.7854 liters 1.0000 gallon

Input

The first line of input contains a single integer N, (1 <= N <= 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a floating point (double precision) number, a space and the unit specification for the measurement to be converted. The unit specification is one of kg, lb, l, or g referring to kilograms, pounds, liters and gallons respectively.

Output

For each dataset, you should generate one line of output with the following values: The dataset number as a decimal integer (start counting at one), a space, and the appropriately converted value rounded to 4 decimal places, a space and the unit specification for the converted value.

Sample Input

5
1 kg
2 l
7 lb
3.5 g
0 l

Sample Output

1 2.2046 lb
2 0.5284 g
3 3.1752 kg
4 13.2489 l
5 0.0000 g


代码如下:

#include <cstdio>
#include <cstring>
int main()
{
    int k = 0;
    double n;
    int t;
    char s[3];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%s",&n,s);
        k++;
        printf("%d ",k);
        if(strcmp(s,"kg") == 0)
        {
            printf("%.4lf lb\n",n*2.2046);
        }
        else if(strcmp(s,"l") == 0)
        {
            printf("%.4lf g\n",n*0.2642);
        }
        else if(strcmp(s,"lb") == 0)
        {
            printf("%.4lf kg\n",n*0.4536);
        }
        else if(strcmp(s,"g") == 0)
        {
            printf("%.4lf l\n",n*3.7854);
        }
    }
    return 0;
}


ZOJ 2988 Conversions(数学啊)

标签:数学   zoj   

原文地址:http://blog.csdn.net/u012860063/article/details/43235015

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!