码迷,mamicode.com
首页 > 其他好文 > 详细

uva 539 The Settlers of Catan(回溯)

时间:2015-01-29 12:45:04      阅读:149      评论:0      收藏:0      [点我收藏+]

标签:uva   c语言   

                             uva 539 The Settlers of Catan

Within Settlers of Catan, the 1995 German game of the year, players attempt to dominate an island by building roads, settlements and cities across its uncharted wilderness.

You are employed by a software company that just has decided to develop a computer version of this game, and you are chosen to implement one of the game‘s special rules:


When the game ends, the player who built the longest road gains two extra victory points.


The problem here is that the players usually build complex road networks and not just one linear path. Therefore, determining the longest road is not trivial (although human players usually see it immediately).


Compared to the original game, we will solve a simplified problem here: You are given a set of nodes (cities) and a set of edges (road segments) of length 1 connecting the nodes. The longest road is defined as the longest path within the network that doesn‘t use an edge twice. Nodes may be visited more than once, though.


Example: The following network contains a road of length 12.

o        o -- o        o
 \      /      \      /
  o -- o        o -- o
 /      \      /      o        o -- o        o -- o
               \      /
                o -- o

Input 

The input file will contain one or more test cases.

The first line of each test case contains two integers: the number of nodes n ( 技术分享) and the number of edges m ( 技术分享). The next m lines describe the m edges. Each edge is given by the numbers of the two nodes connected by it. Nodes are numbered from 0 to n-1. Edges are undirected. Nodes have degrees of three or less. The network is not neccessarily connected.

Input will be terminated by two values of 0 for n and m.

Output 

For each test case, print the length of the longest road on a single line.

Sample Input 

3 2
0 1
1 2
15 16
0 2
1 2
2 3
3 4
3 5
4 6
5 7
6 8
7 8
7 9
8 10
9 11
10 12
11 12
10 13
12 14
0 0

Sample Output 

2
12


题目大意:给出一个连接图,求最长不重复路径,输出值。

解题思路:深搜查找最长路径。



#include<stdio.h>
#include<string.h>
int gra[30][30], vis[30][30], ans;
int n, m;
void DFS(int i, int len) {
	for (int j = 0; j < n; j++) {
		if (gra[i][j] && !vis[i][j]) {
			vis[i][j] = vis[j][i] = 1;
			DFS(j, len + 1);
			vis[i][j] = vis[j][i] = 0;
		}
	}
	if (len > ans) {
		ans = len;
	}
}
int main() {
	while (scanf("%d %d", &n, &m) == 2, n, m) {
		memset(gra, 0, sizeof(gra));
		memset(vis, 0, sizeof(vis));
		int a, b;	
		for (int i = 0; i < m; i++) {
			scanf("%d %d", &a, &b);
			gra[a][b] = gra[b][a] = 1;
		}
		ans = 0;
		for (int i = 0; i < n; i++) {
			for (int j = 0; j < n; j++) {
				if (gra[i][j]) {
					vis[i][j] = vis[j][i] = 1;
					DFS(i, 1);
					vis[i][j] = vis[j][i] = 0;
				}
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}


uva 539 The Settlers of Catan(回溯)

标签:uva   c语言   

原文地址:http://blog.csdn.net/llx523113241/article/details/43268469

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!