码迷,mamicode.com
首页 > 其他好文 > 详细

杭电二分题

时间:2015-01-29 17:41:59      阅读:215      评论:0      收藏:0      [点我收藏+]

标签:二分查找

Description

Now, here is a fuction: 
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100) 
Can you find the minimum value when x is between 0 and 100.
 

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input

2 100 200
 

Sample Output

-74.4291 -178.8534
 
#include<iostream>
#include <iomanip>
using namespace std;
long double fun(double x)
{
	return 42*x*x*x*x*x*x+48*x*x*x*x*x+21*x*x+10*x ;
}
long double fun1(double x,double y)
{
	return 6*x*x*x*x*x*x*x+8*x*x*x*x*x*x+7*x*x*x+5*x*x - y*x ;
}
int main()
{
	int t;
	long double y,hight=100,low=0,mid,k;
	cin >> t ;
	while(t--)
	{
		cin >> y;
		hight=100;
		low=0;
		while(hight - low >1e-8)
		{
			mid=(hight + low)/2;
			k=fun(mid);
			if(k>y)
			{
				hight=mid;
			}
			if(k<y)
			{
				low=mid;
			}
		}
		cout << setiosflags(ios::fixed) ;
		cout << setprecision(4) << fun1(mid , y) << endl;
	}
	return 0;
}

杭电二分题

标签:二分查找

原文地址:http://blog.csdn.net/zsc2014030403015/article/details/43272941

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!