码迷,mamicode.com
首页 > 其他好文 > 详细

uva 12097 Pie(二分搜索)

时间:2015-01-29 17:50:43      阅读:174      评论:0      收藏:0      [点我收藏+]

标签:uva   c语言   

                             uva 12097 Pie

My birthday is coming up and traditionally I‘m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:

  • One line with two integers N and F with 1 ≤ N, F ≤ 10000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10-3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655



题目大意:有N个pie,分给F+1个人,使得分给每个人的面积尽量大,每个人分得的pie都是整块的,不能是有几块拼凑起来的。

解题思路:二分答案。



#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
#define Pi 3.141592653589
double S[10005], Max;
int n, f;
int check(double x) { //判断一人x面积派,是否够分
	int sum = 0;
	for (int i = 0; i < n; i++) {
		sum += floor(S[i] / x);
	}
	if (sum >= (f + 1)) return 1;
	else return 0;
}
int main() {
	int	T;
	scanf("%d", &T);
	while (T--) {
		memset(S, 0, sizeof(S));
		scanf("%d %d", &n, &f);
		int a;
		Max = 0;
		for (int i = 0; i < n; i++) {
			scanf("%d", &a);
			S[i] = Pi * a * a;
			Max = max(Max, S[i]);
		}
		double R = Max, L = 0;
		while (R - L > 1e-5) {
			double mid = (R + L) / 2;//二分法,若人均mid够分则向上二分,反之向下二分,知道RL趋近
			if (check(mid)) L = mid;
			else R = mid;
		}
		printf("%.4lf\n", R);
	}
	return 0;
}



uva 12097 Pie(二分搜索)

标签:uva   c语言   

原文地址:http://blog.csdn.net/llx523113241/article/details/43272299

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!