码迷,mamicode.com
首页 > 其他好文 > 详细

(并查集) hdu 3635

时间:2015-01-29 19:31:31      阅读:166      评论:0      收藏:0      [点我收藏+]

标签:

Dragon Balls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3443    Accepted Submission(s): 1342


Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it‘s too difficult for Monkey King(WuKong) to gather all of the dragon balls together. 
技术分享

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities‘ dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. 
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.
 

 

Input
The first line of the input is a single positive integer T(0 < T <= 100). 
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
 

 

Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
 

 

Sample Input
2 3 3 T 1 2 T 3 2 Q 2 3 4 T 1 2 Q 1 T 1 3 Q 1
 

 

Sample Output
Case 1: 2 3 0 Case 2: 2 2 1 3 3 2
 

 

Author
possessor WC
 

 

压缩路径需要多想想

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<cstdlib>
using namespace std;
#define maxn 1000010
int n,tt,m,fa[maxn],city[maxn],trans[maxn];
char s[10];
int find(int x)
{
      if(x==fa[x])
            return x;
      int k=fa[x];
      fa[x]=find(fa[x]);
      trans[x]+=trans[k];
      return fa[x];
}
void Union(int x,int y)
{
      int fx,fy;
      fx=find(x),fy=find(y);
      if(fx!=fy)
      {
            fa[fx]=fy;
            trans[fx]++;
            city[fy]+=city[fx];
            city[fx]=0;
      }
}
int main()
{
      int a,b,cas=1;
      scanf("%d",&tt);
      while(tt--)
      {
            printf("Case %d:\n",cas);
            scanf("%d%d",&n,&m);
            for(int i=0;i<=n;i++)
                  fa[i]=i,city[i]=1,trans[i]=0;
            for(int i=0;i<m;i++)
            {
                  scanf("%s",s);
                  if(s[0]==‘T‘)
                  {
                       scanf("%d%d",&a,&b);
                       Union(a,b);
                  }
                  else if(s[0]==‘Q‘)
                  {
                        scanf("%d",&a);
                        int k=find(a);
                        printf("%d %d %d\n",k,city[k],trans[a]);
                  }
            }
            cas++;
      }
      return 0;
}

  

(并查集) hdu 3635

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4260578.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!