码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 3047

时间:2015-01-29 20:48:43      阅读:153      评论:0      收藏:0      [点我收藏+]

标签:

Zjnu Stadium

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1755    Accepted Submission(s): 664


Problem Description
In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.
 

 

Input
There are many test cases:
For every case: 
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

 

 

Output
For every case: 
Output R, represents the number of incorrect request.
 

 

Sample Input
10 10 1 2 150 3 4 200 1 5 270 2 6 200 6 5 80 4 7 150 8 9 100 4 8 50 1 7 100 9 2 100
 

 

Sample Output
2
Hint
Hint: (PS: the 5th and 10th requests are incorrect)

是求出节点a到根的距离。第二行代码使用的是数学中向量计算的原理如图

技术分享

数学问题,看成向量来解决

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
using namespace std;
#define maxn 1000010
int n,m,fa[maxn],dist[maxn],ans;
int find(int x)
{
      if(x==fa[x])
            return fa[x];
      int k=fa[x];
      fa[x]=find(fa[x]);
      dist[x]+=dist[k];
      return fa[x];
}
void Union(int x,int y,int z)
{
      int fx,fy;
      fx=find(x),fy=find(y);
      if(fx!=fy)
      {
            fa[fx]=fy;
            dist[fx]=dist[y]-dist[x]+z;
      }
      else
      {
            if(dist[x]-dist[y]!=z)
                  ans++;
      }
}
int main()
{
      int x,y,z;
      while(scanf("%d%d",&n,&m)!=EOF)
      {
            ans=0;
            for(int i=0;i<=n;i++)
                  fa[i]=i,dist[i]=0;
            for(int i=0;i<m;i++)
            {
                scanf("%d%d%d",&x,&y,&z);
                Union(x,y,z);
            }
            printf("%d\n",ans);
      }
      return 0;
}

  

hdu 3047

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4260700.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!