码迷,mamicode.com
首页 > 其他好文 > 详细

HDU2138 How many prime numbers【水题】

时间:2015-01-29 22:35:12      阅读:234      评论:0      收藏:0      [点我收藏+]

标签:

How many prime numbers

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12742    Accepted Submission(s): 4400

Problem Description
Give you a lot of positive integers, just to find out how many prime numbers there are.
 
Input
There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.
 
Output
For each case, print the number of prime numbers you have found out.
 
Sample Input
3
2 3 4
 
Sample Output
2
 
Author
wangye
 
Source

HDU 2007-11 Programming Contest_WarmUp


题目大意:给你N个数,判断N个数里素数的个数。

思路:直接暴力来做。


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;

int main()
{
    int N,d;
    while(cin >> N)
    {
        int sum = 0,j;
        for(int i = 0; i < N; ++i)
        {
            cin >> d;
            for(j = 2; j <= sqrt(1.0*d); j++)
            {
                if(d % j == 0)
                    break;
            }
            if(j > sqrt(1.0*d))
                sum++;
        }
        cout << sum << endl;
    }

    return 0;
}


HDU2138 How many prime numbers【水题】

标签:

原文地址:http://blog.csdn.net/lianai911/article/details/43280737

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!