码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2752 Seek the Name, Seek the Fame kmp失配函数next应用

时间:2015-01-30 00:09:14      阅读:198      评论:0      收藏:0      [点我收藏+]

标签:


Seek the Name, Seek the Fame
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 12791   Accepted: 6304

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father‘s name and the mother‘s name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father=‘ala‘, Mother=‘la‘, we have S = ‘ala‘+‘la‘ = ‘alala‘. Potential prefix-suffix strings of S are {‘a‘, ‘ala‘, ‘alala‘}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby‘s name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

Source


给你一个字符串,求所有前缀等于后缀的情况。
next数组的应用,KMP求出next数组,每次去掉next[i]到i的一段字符,剩余字串仍满足条件,直到找到头为止。
next[i]!=0的,都是模式串的前缀和后缀相同的字符数。
//3892K	547MS
#include<stdio.h>
#include<string.h>
#define M 10007
char pattern[400007];
int next[400007],m,ans[400007];
void pre(int len)
{
    int i = 0, j = -1;
    next[0] = -1;
    while(i != len)
    {
        if(j == -1 || pattern[i] == pattern[j])
            next[++i] = ++j;
        else
            j = next[j];
    }
}
int main()
{
    while(scanf("%s",pattern)!=EOF)
    {
        memset(ans,0,sizeof(ans));
        memset(next,0,sizeof(next));
        m=strlen(pattern);
        pre(m);
        int k=0;
        for(int i=m; i!=0; )
        {
            ans[k++]=next[i];
            i=next[i];
        }
        for(int i=k-2; i>=0; i--)
            printf("%d ",ans[i]);
        printf("%d\n",m);
    }
    return 0;
}


POJ 2752 Seek the Name, Seek the Fame kmp失配函数next应用

标签:

原文地址:http://blog.csdn.net/crescent__moon/article/details/43282391

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!