码迷,mamicode.com
首页 > 其他好文 > 详细

(贪心) hdu 3183

时间:2015-01-30 15:45:46      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:

A Magic Lamp

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1858    Accepted Submission(s): 727


Problem Description
Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams. 
The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum.
You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream?
 

 

Input
There are several test cases.
Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero.
 

 

Output
For each case, output the minimum result you can get in one line.
If the result contains leading zero, ignore it. 
 

 

Sample Input
178543 4 1000001 1 100001 2 12345 2 54321 2
 

 

Sample Output
13 1 0 123 321
 

 

Source
 

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<cmath>
using namespace  std;
char s[10010];
int n,len;
void work()
{
      int temp=n;
      while(temp--)
      {
            int i=0;
            while(i<len-1&&s[i]<=s[i+1]) i++;
            for(int j=i+1;j<len;j++)
                  s[j-1]=s[j];
      }
}
int main()
{
      while(scanf("%s%d",s,&n)!=EOF)
      {
            len=strlen(s);
            if(n>=len)
            {
                  printf("0\n");
                  continue;
            }
            work();
            bool flag=false;
            for(int i=0;i<len-n;i++)
            {
                  if(!flag&&(s[i]==‘0‘&&i!=len-n-1))
                        continue;
                  else
                  {
                        printf("%c",s[i]);
                        flag=1;
                  }
            }
            printf("\n");
            memset(s,‘0‘,sizeof(s));
      }
      return 0;
}

  

(贪心) hdu 3183

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4262252.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!