码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2184 Cow Exhibition

时间:2015-01-30 16:00:14      阅读:102      评论:0      收藏:0      [点我收藏+]

标签:poj   编程   algorithm   acm   

Cow Exhibition
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9564   Accepted: 3690

Description

"Fat and docile, big and dumb, they look so stupid, they aren‘t much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si‘s and, likewise, the total funness TF of the group is the sum of the Fi‘s. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 

allowed. 


       给出n个牛的聪明值和幽默值,在这些牛里选出部分牛,使选出牛的聪明值和幽默值得和最大,聪明值的和和幽默值的和都不能为负数

     将聪明值看成容积,幽默值看成价值,用01背包,但是出现了负数,dp[i]代表体积,将其整体平移100000就可解决了,另外当聪明值为负值时,要从小到大进行背包才能保证每个只用了一次。

   


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=200000+100;
const int inf=1<<30;
int dp[maxn];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int u,v;
        for(int i=0;i<maxn;i++)
        dp[i]=-inf;
        dp[100000]=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&u,&v);
            if(u<0&&v<0)
            continue;
            if(u>0)
            for(int j=200000;j>=u;j--)
            {
                if(dp[j-u]>=-inf)
                dp[j]=max(dp[j-u]+v,dp[j]);
            }
            else
            {
                for(int j=u;j<=200000+u;j++)
                {
                    if(dp[j-u]>=-inf)
                    dp[j]=max(dp[j-u]+v,dp[j]);
                }
            }
        }
        int ans=0;
        for(int i=100000;i<=200000;i++)
        if(dp[i]>=0)
        ans=max(ans,dp[i]+i-100000);
        printf("%d\n",ans);
    }
    return 0;
}


POJ 2184 Cow Exhibition

标签:poj   编程   algorithm   acm   

原文地址:http://blog.csdn.net/caduca/article/details/43305791

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!