码迷,mamicode.com
首页 > 其他好文 > 详细

Encoding

时间:2015-01-31 11:58:49      阅读:171      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
Given a string containing only ‘A‘ - ‘Z‘, we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, ‘1‘ should be ignored.
 

 

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only ‘A‘ - ‘Z‘ and the length is less than 10000.
 

 

Output
For each test case, output the encoded string in a line.
 

 

Sample Input
2 ABC ABBCCC
 

 

Sample Output
ABC A2B3C
 

 

Author
ZHANG Zheng
 

 

技术分享
#include<cstdio>
#include<cstring>
int main()
{
    int N;
    int a[130];
    int v;
    int temp=0;
    scanf("%d",&N);
    getchar();
    while(N--)
    {
        memset(a,0,sizeof(a));
        v=getchar();
        temp=v;
        while(temp!=\n)
        {

            if(v!=temp)
            {
                if(a[temp]>1) printf("%d%c",a[temp],temp);
                if(a[temp]==1) printf("%c",temp);
                a[temp]=0;
                a[v]++;
            }
            else a[v]++;
            temp=v;
            if(v!=\n) v=getchar();
        }
        printf("\n");
    }
}
/*题意没看清,wa了几次,题目说了是子序列,那么对于例子 AABBBCCCAABB  应输出2A3B3C2A2B*/
View Code

 

Encoding

标签:

原文地址:http://www.cnblogs.com/orchidzjl/p/4263744.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!