码迷,mamicode.com
首页 > 其他好文 > 详细

(最大生成树) poj 3727

时间:2015-01-31 20:34:31      阅读:149      评论:0      收藏:0      [点我收藏+]

标签:

Conscription
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8330   Accepted: 2894

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boyy have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<cstdlib>
#include<string>
using namespace std;
int fa[100010],n,m,r;
struct node
{
      int x,y,w;
}e[100010];
bool cmp(node a,node b)
{
      return a.w>b.w;
}
int find(int x)
{
      return x==fa[x]?x:fa[x]=find(fa[x]);
}
int main()
{
      int tt;
      scanf("%d",&tt);
      while(tt--)
      {
            int ans=0;
            scanf("%d%d%d",&n,&m,&r);
            for(int i=0;i<=n+m;i++)
                  fa[i]=i;
            for(int i=1;i<=r;i++)
            {
                  scanf("%d%d%d",&e[i].x,&e[i].y,&e[i].w);
                  e[i].y+=n;
            }
            sort(e+1,e+1+r,cmp);
            for(int i=1;i<=r;i++)
            {
                  int fx,fy;
                  fx=find(e[i].x),fy=find(e[i].y);
                  if(fx!=fy)
                  {
                        fa[fx]=fy;
                        ans+=e[i].w;
                  }
            }
            printf("%d\n",(n+m)*10000-ans);
      }
      return 0;
}

  

(最大生成树) poj 3727

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4264656.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!