码迷,mamicode.com
首页 > 其他好文 > 详细

uva 10305 Ordering Tasks (简单拓扑)

时间:2015-02-01 13:33:21      阅读:167      评论:0      收藏:0      [点我收藏+]

标签:uva   c语言   

                            uva 10305 Ordering Tasks



John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.

Input

The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 <= n <= 100 and m. n is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance with n = m = 0 will finish the input.

Output

For each instance, print a line with n integers representing the tasks in a possible order of execution.

Sample Input

5 4
1 2
2 3
1 3
1 5
0 0

Sample Output

1 4 2 5 3



题目大意:拓扑排序。

解题思路:简单拓扑。


#include<stdio.h>
#include<string.h>
int gra[105][105], degree[105];
int n, m;
int main() {
	while (scanf("%d %d", &n, &m) == 2, (n || m)) {
		memset(gra, 0, sizeof(gra));
		memset(degree, 0, sizeof(degree));
		int a, b;
		for (int i = 0; i < m; i++) {
			scanf("%d %d", &a, &b);
			if (!gra[a][b]) {
				gra[a][b] = 1;
				degree[b]++;
			}
		}
		for (int i = 1; i <= n; i++) {
			for (int j = 1; j <= n; j++) {
				if (degree[j] == 0) {
					degree[j]--;
					if (i != n) printf("%d ", j);
					else printf("%d", j);
					for (int k = 1; k <= n; k++) {
						if (gra[j][k]) {
							degree[k]--;
						}
					}
					break;
				}
			}
		}
		printf("\n");
	}
}



uva 10305 Ordering Tasks (简单拓扑)

标签:uva   c语言   

原文地址:http://blog.csdn.net/llx523113241/article/details/43370691

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!