码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1728 逃离迷宫 【BFS】

时间:2015-02-01 20:32:11      阅读:289      评论:0      收藏:0      [点我收藏+]

标签:hdu1728

逃离迷宫

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16840    Accepted Submission(s): 4108


Problem Description
  给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?
 

Input
  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,
  第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符‘.‘表示该位置为空地,字符‘*‘表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x1, y1, x2, y2 (1 ≤ k ≤ 10, 1 ≤ x1, x2 ≤ n, 1 ≤ y1, y2 ≤ m),其中k表示gloria最多能转的弯数,(x1, y1), (x2, y2)表示两个位置,其中x1,x2对应列,y1, y2对应行。
 

Output
  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。
 

Sample Input
2 5 5 ...** *.**. ..... ..... *.... 1 1 1 1 3 5 5 ...** *.**. ..... ..... *.... 2 1 1 1 3
 

Sample Output
no yes

#include <stdio.h>
#include <string.h>

#define maxn 105
const int dir[][2] = {0, 1, 0, -1, 1, 0, -1, 0};

struct Node {
	int x, y, step;
} que[maxn * maxn]; // 点不能重复入队,但能重复走
int M, N, K, X, Y; // M rows
char G[maxn][maxn];

bool check(int x, int y) {
	return x >= 1 && x <= M && y >= 1 && y <= N && G[x][y] != '*';
}

bool BFS(int x0, int y0) {
	Node u, v;
	int front = 0, back = 0, i;

	G[x0][y0] = '*';
	u.x = x0; u.y = y0; u.step = -1;
	que[back++] = u;
	while (front != back) {
		u = que[front++];
		if (u.x == X && u.y == Y) return true;
		if (u.step == K) continue;
		for (i = 0; i < 4; ++i) {
			v = u;
			++v.step;
			while (true) {
				v.x += dir[i][0];
				v.y += dir[i][1];
				if (!check(v.x, v.y)) break;
				if (G[v.x][v.y] == '.') que[back++] = v;
				G[v.x][v.y] = '@'; // mark
			}
		}
	}
	return false;
} 

int main() {
	// freopen("stdin.txt", "r", stdin);
	int x0, y0, T, i;
	scanf("%d", &T);
	while (T--) {
		scanf("%d%d", &M, &N);
		for (i = 1; i <= M; ++i)
			scanf("%s", G[i] + 1);
		scanf("%d%d%d%d%d", &K, &y0, &x0, &Y, &X);
		puts(BFS(x0, y0) ? "yes" : "no");
	}
	return 0;
}


HDU1728 逃离迷宫 【BFS】

标签:hdu1728

原文地址:http://blog.csdn.net/chang_mu/article/details/43373575

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!