码迷,mamicode.com
首页 > 其他好文 > 详细

最长上升子序列 POJ2533

时间:2015-02-02 10:54:35      阅读:145      评论:0      收藏:0      [点我收藏+]

标签:poj

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1a2, ..., aN) be any sequence (ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4
#include <cstdio>
#include <memory.h>
#define MAX_N 1000
int b[MAX_N+10];
int aMaxLen[MAX_N+10] ;
void main()
{
	int N,i;
	while(scanf("%d",&N))
	{
		for (i=1;i<=N; ++i)
		{
			scanf("%d",&b[i]);
		}
		aMaxLen[1]=1;
		for (i=2;i<=N;++i)
		{
			int nTmp = 0;
			for (int j = 1;j<i;++j)
			{
				if (b[i]>b[j])
				{
					if (nTmp < aMaxLen[j])
					{
						nTmp = aMaxLen[j] ;
					}
				}
			}
			aMaxLen[i] = nTmp + 1 ;
		}
		/*for (i=0;i<=N;++i)
		{
			printf("%d ",aMaxLen[i]);
		}
		printf("\n");*/
		int nMax = -1;
		for (i=1;i<=N;++i)
		{
			if (nMax<aMaxLen[i])
			{
				nMax =aMaxLen[i] ;
			}
		}
		printf("%d\n",nMax);
	}
}


最长上升子序列 POJ2533

标签:poj

原文地址:http://blog.csdn.net/zsc2014030403015/article/details/43404989

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!